CH-J Toolsการจัดการเซิร์ฟเวอร์ผ่าน SSH
เมนู
คู่มือและบทความทั้งหมด →

ตัวอย่างคีย์ OpenPGP: V2–V6 แบบดั้งเดิมและหลังควอนตัม

คีย์ทดสอบ OpenPGP สังเคราะห์ 44 คีย์ที่สร้างด้วย CH-J Tools แยกหมวดหมู่ตามคีย์ ตั้งแต่รุ่น 6 ถึงรุ่น 2 ในอดีต พร้อมรุ่นคีย์ ข้อกำหนด ลายนิ้วมือ คีย์สาธารณะ คีย์ส่วนตัว ใบรับรองการเพิกถอน และลายเซ็นแบบแยกของไฟล์ทดสอบขนาด 1 MB

เนื้อหาของหน้านี้

แต่ละหมวดหมู่คือตัวตน OpenPGP ที่สมบูรณ์ซึ่งสร้างด้วยเครื่องมือสร้างคีย์ของ CH-J Tools ได้แก่ คีย์รุ่น 6 (RFC 9580) ที่ใช้อัลกอริทึมแบบดั้งเดิมและหลังควอนตัม (RFC 9980) คีย์ LibrePGP รุ่น 5 และคีย์รุ่น 4 เพื่อความเข้ากันได้ รวมขนาด RSA แบบเก่า รวมถึงคีย์ RSA รุ่น 3 และรุ่น 2 ที่เก็บไว้เพื่อประวัติศาสตร์เท่านั้น คีย์ตั้งแต่รุ่น 4 มีคีย์หลักสำหรับลงนามและคีย์ย่อยสำหรับเข้ารหัสหนึ่งคีย์ รุ่น 3 และ 2 ไม่มีคีย์ย่อย ใช้ไฟล์เพื่อทดสอบการนำเข้า การตรวจสอบลายเซ็น การเข้ารหัส และการจัดการการเพิกถอนในซอฟต์แวร์ OpenPGP ของคุณ

คีย์สำหรับทดสอบเท่านั้น

คีย์เหล่านี้เป็นคีย์สังเคราะห์ เราจงใจเผยแพร่คีย์ส่วนตัวและวลีรหัสผ่าน ทุกคนจึงลงนามหรือถอดรหัสด้วยคีย์เหล่านี้ได้ ห้ามใช้กับข้อมูลจริง และห้ามเชื่อถือลายเซ็นเพียงเพราะตรวจสอบผ่านด้วยคีย์ใดคีย์หนึ่งในชุดนี้

เหตุใดบางโปรแกรมจึงปฏิเสธคีย์บางชนิด

การรองรับรุ่นและอัลกอริทึม OpenPGP แตกต่างกัน GnuPG 2.4 อ่านรุ่น 4 และ 5 ได้ แต่ไม่รองรับรุ่น 6 หรืออัลกอริทึมหลังควอนตัม RFC 9980 ส่วน Sequoia อ่านรุ่น 4 และ 6 ได้ แต่ไม่รองรับ LibrePGP รุ่น 5, secp256k1 หรือ RSA ต่ำกว่า 2048 บิต คีย์รุ่น 3 และ 2 ใช้ MD5 และ IDEA อ่านได้เฉพาะด้วย GnuPG 1.4 ที่อนุญาตไดเจสต์ที่อ่อนแอ หรือ PGP ในอดีต แต่ละหมวดหมู่ระบุข้อกำหนดและอัลกอริทึม การปฏิเสธคีย์จึงมักหมายถึงขาดคุณสมบัติ มากกว่าไฟล์เสียหาย

ไฟล์ทดสอบ

ลายเซ็นทั้ง 44 รายการครอบคลุมไฟล์ข้อมูลสุ่มขนาด 1 MB ไฟล์เดียวนี้ ดาวน์โหลดครั้งเดียวและเปรียบเทียบเช็กซัม SHA-256 ก่อนตรวจสอบลายเซ็นใด ๆ

ดาวน์โหลด test_1MB.bin 1 048 576 ไบต์

SHA-256  10055956fa0fdd963344a0d80a3b9ccf3ed1d331569a23d8223bbf2e460ae972  test_1MB.bin

หมวดหมู่

รุ่น 6 · หลังควอนตัม (RFC 9580 + RFC 9980)

รุ่น 6 · อัลกอริทึมแบบดั้งเดิม (RFC 9580)

รุ่น 5 · LibrePGP (draft-koch-librepgp-06)

รุ่น 4 · ความเข้ากันได้ (RFC 2440 · RFC 4880 · RFC 9580)

รุ่น 3 · legacy (RFC 1991 · RFC 2440 · RFC 4880)

รุ่น 2 · legacy (RFC 1991 · RFC 2440)